aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 21:23:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 00:47:03 +0100
commit7acc52f98bf471e7bd3858ac821f6080613d87be (patch)
tree15b82fb4aa02a38abe83764983297d5a9fad8deb
parent836931a5a7036279310ecc955fbdebca3574ab47 (diff)
downloadguix-7acc52f98bf471e7bd3858ac821f6080613d87be.tar
guix-7acc52f98bf471e7bd3858ac821f6080613d87be.tar.gz
gnu: mlt: Update to 6.12.0.
* gnu/packages/video.scm (mlt): Update to 6.12.0. [arguments]: Re-indent.
-rw-r--r--gnu/packages/video.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b7f79aa483..12eb933966 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2039,7 +2039,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(define-public mlt
(package
(name "mlt")
- (version "6.10.0")
+ (version "6.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2048,16 +2048,10 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ki86yslr5ywa6sz8pjrgd9a4rn2rr4mss2zkmqi7pq8prgsm1fr"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; As of glibc 2.26, <xlocale.h> no longer is.
- (substitute* "src/framework/mlt_property.h"
- (("xlocale\\.h") "locale.h"))
- #t))))
+ "0pzm3mjbbdl2rkbswgyfkx552xlxh2qrwzsi2a4dicfr92rfgq6w"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:make-flags '("CC=gcc" "CXX=g++ -std=gnu++11")
#:configure-flags
(list "--enable-gpl3"
@@ -2065,14 +2059,14 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
#:phases
(modify-phases %standard-phases
(add-after
- 'configure 'override-LDFLAGS
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "config.mak"
- (("LDFLAGS\\+=")
- (string-append "LDFLAGS+=-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib ")))
- #t)))))
+ 'configure 'override-LDFLAGS
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "config.mak"
+ (("LDFLAGS\\+=")
+ (string-append "LDFLAGS+=-Wl,-rpath="
+ (assoc-ref outputs "out")
+ "/lib ")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg-3.4)