aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 16:28:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 18:07:03 +0100
commit7953675fc018ff8bc67a2266a9515f054769de0c (patch)
tree5fcaf09ca146dc492e9f0007172484dad09e207d
parente28f3cd9f0b71421b7ef895b6d5a6638943fa15b (diff)
downloadguix-7953675fc018ff8bc67a2266a9515f054769de0c.tar
guix-7953675fc018ff8bc67a2266a9515f054769de0c.tar.gz
gnu: scrot: Update to 0.9.
* gnu/packages/xdisorg.scm (scrot): Update to 0.9. [source, home-page]: Switch to new (git) upstream. [arguments]: Remove them. [native-inputs]: Add autoconf and automake.
-rw-r--r--gnu/packages/xdisorg.scm49
1 files changed, 17 insertions, 32 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 52e7edf6e1..df7833bcb3 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
@@ -455,39 +455,24 @@ move windows, switch between desktops, etc.).")
(define-public scrot
(package
(name "scrot")
- (version "0.8")
- (source (origin
- (method url-fetch)
- (uri (list (string-append
- "http://linuxbrit.co.uk/downloads/scrot-"
- version ".tar.gz")
- (string-append
- "https://fossies.org/linux/privat/old/scrot-"
- version ".tar.gz")))
- (sha256
- (base32
- "1wll744rhb49lvr2zs6m93rdmiq59zm344jzqvijrdn24ksiqgb1"))))
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/resurrecting-open-source-projects/scrot.git")
+ (commit version)))
+ (sha256
+ (base32 "1dg0pnmk09p7zlbyxv7d40vf54amrv73y976ds5p7096x6lmlndy"))))
(build-system gnu-build-system)
- (arguments
- ;; By default, man and doc are put in PREFIX/{man,doc} instead of
- ;; PREFIX/share/{man,doc}.
- '(#:configure-flags
- (list (string-append "--mandir="
- (assoc-ref %outputs "out")
- "/share/man"))
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/scrot")))
- (mkdir-p doc)
- (invoke "make" "install"
- (string-append "docsdir=" doc))))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
(inputs
- `(("libx11" ,libx11)
- ("giblib" ,giblib)))
- (home-page "http://linuxbrit.co.uk/software/")
+ `(("giblib" ,giblib)
+ ("libx11" ,libx11)))
+ (home-page "https://github.com/resurrecting-open-source-projects/scrot")
(synopsis "Command-line screen capture utility for X Window System")
(description
"Scrot allows to save a screenshot of a full screen, a window or a part