aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-18 21:39:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-18 21:39:54 +0100
commit30f08487261f332cb03e4b2e06c12fc41e508c52 (patch)
tree0514fcdba0c9bf2f2a3df1196e35f98445250aee
parent34372d3905e17c880180f811e5b5f83e423e9025 (diff)
downloadguix-30f08487261f332cb03e4b2e06c12fc41e508c52.tar
guix-30f08487261f332cb03e4b2e06c12fc41e508c52.tar.gz
gnu: Add ruby-rsync.
* gnu/packages/ruby.scm (ruby-rsync): New variable.
-rw-r--r--gnu/packages/ruby.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 50bf56d87b..6da7109d14 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages ragel)
+ #:use-module (gnu packages rsync)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
@@ -263,6 +264,41 @@ packaging native C and Java extensions in Ruby.")
(home-page "https://github.com/rake-compiler/rake-compiler")
(license license:expat)))
+(define-public ruby-rsync
+ (package
+ (name "ruby-rsync")
+ (version "1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rsync" version))
+ (sha256
+ (base32
+ "0p8b27q1gvxilqfq2528xpwglzcm2myikkjxpqk7mwbwg9r6knxv"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-coveralls-requirement
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("require 'coveralls'") "")
+ (("Coveralls.wear!") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("rsync" ,rsync)
+ ("ruby-rspec-core" ,ruby-rspec-core)
+ ("ruby-rspec-expectations" ,ruby-rspec-expectations)
+ ("ruby-rspec-mocks" ,ruby-rspec-mocks)))
+ (home-page "https://github.com/jbussdieker/ruby-rsync")
+ (synopsis "Ruby wrapper around rsync")
+ (description
+ "Ruby Rsync is a Ruby library that can synchronize files between remote
+hosts by wrapping the @file{rsync} binary.")
+ (license license:expat)))
+
(define-public ruby-i18n
(package
(name "ruby-i18n")