aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 23:58:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 00:47:03 +0100
commit217ea1a1be0e451f8229809913ade15bbaef651c (patch)
tree3be4f695758a33c8e2dc1b7eebee24b4710554f0
parent249deec95fbf291c50e8fda74cf83f8e0109bd0b (diff)
downloadguix-217ea1a1be0e451f8229809913ade15bbaef651c.tar
guix-217ea1a1be0e451f8229809913ade15bbaef651c.tar.gz
gnu: python-qrcode: Update to 6.1.
* gnu/packages/python-xyz.scm (python-qrcode): Update to 6.1. [inputs]: Remove python-setuptools.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 811cbaf03e..835b5c8a8a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017, 2018 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -10873,14 +10873,13 @@ a file-like object from which an arbitrarly-sized key can be read.")
(define-public python-qrcode
(package
(name "python-qrcode")
- (version "6.0")
+ (version "6.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "qrcode" version))
(sha256
- (base32
- "1gz1g2n9kqwqkak78aavr354z1v3yyiksk7q6xp5hi1zr6s0syq3"))))
+ (base32 "0sa3n298b9jpz6zn0birnjii3mg9sihjq28n9nzjlzv09y2m6ljh"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests require packaging 'pymaging'.
@@ -10889,10 +10888,6 @@ a file-like object from which an arbitrarly-sized key can be read.")
`(("python-lxml" ,python-lxml) ; for SVG output
("python-pillow" ,python-pillow) ; for PNG output
("python-six" ,python-six)))
- (inputs
- `(;; The setup.cfg file needs to be used, and support for this requires
- ;; at least version 30.3.0 of setuptools
- ("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/lincolnloop/python-qrcode")
(synopsis "QR Code image generator")
(description "This package provides a pure Python QR Code generator