aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 14:29:30 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:31 -0500
commit215f3db0e3c91bbe13db5a73b50e998c03cfbe7c (patch)
treeb608ef818f8f02cf7e2a8d08dda6e4e4db820c0b
parentfc681a18f52635e4bd1dbc9e962e57930f0c7ad3 (diff)
downloadguix-215f3db0e3c91bbe13db5a73b50e998c03cfbe7c.tar
guix-215f3db0e3c91bbe13db5a73b50e998c03cfbe7c.tar.gz
gnu: Add python-txtorcon.
* gnu/packages/python-crypto.scm (python-txtorcon): New variable.
-rw-r--r--gnu/packages/python-crypto.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6ca82cb061..4338854574 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1036,3 +1036,33 @@ Derivation function (HKDF) defined in RFC 5869.")
(description "This package provides a Python implementation of the SPAKE2
Password-Authenticated Key Exchange algorithm.")
(license license:expat)))
+
+(define-public python-txtorcon
+ (package
+ (name "python-txtorcon")
+ (version "19.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "txtorcon" version))
+ (sha256
+ (base32
+ "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests fail immediately due to a missing file. Reported upstream:
+ ;; <https://github.com/meejah/txtorcon/issues/330>
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-automat" ,python-automat)
+ ("python-idna" ,python-idna)
+ ("python-incremental" ,python-incremental)
+ ("python-ipaddress" ,python-ipaddress)
+ ("python-service-identity" ,python-service-identity)
+ ("python-twisted" ,python-twisted)
+ ("python-zope-interface" ,python-zope-interface)))
+ (home-page "https://github.com/meejah/txtorcon")
+ (synopsis "Twisted-based Tor controller client")
+ (description "This package provides a Twisted-based Tor controller client,
+with state-tracking and configuration abstractions.")
+ (license license:expat)))