aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-17 14:13:46 -0500
committerLeo Famulari <leo@famulari.name>2019-02-19 14:34:30 -0500
commit00adbac6d2b56fb3f61879292f5391aece80d749 (patch)
treecddda081aab796061656e6ad5a07e66d6cc6297d
parente5ba2fe30abe7ed213caa34580ac66b7fc080939 (diff)
downloadguix-00adbac6d2b56fb3f61879292f5391aece80d749.tar
guix-00adbac6d2b56fb3f61879292f5391aece80d749.tar.gz
gnu: Add python-treq.
* gnu/packages/python-web.scm (python-treq): New variable.
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 052331cc44..ec7f43945e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2973,3 +2973,29 @@ ecosystem.")
(description "This package provides a Python module to create immutable, and
correct URLs for Python according to RFCs 3986 and 3987.")
(license license:expat)))
+
+(define-public python-treq
+ (package
+ (name "python-treq")
+ (version "18.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "treq" version))
+ (sha256
+ (base32
+ "0j4zwq9p1c9piv1vc66nxcv9s6hdinf90jwkbsm91k14npv9zq4i"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-idna" ,python-idna)
+ ("python-incremental" ,python-incremental)
+ ("python-requests" ,python-requests)
+ ("python-service-identity" ,python-service-identity)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://github.com/twisted/treq")
+ (synopsis "Requests-like API built on top of twisted.web's Agent")
+ (description "This package provides an HTTP library inspired by
+@code{requests}} but written on top of Twisted's @code{Agents}. It offers a
+high level API for making HTTP requests when using Twisted.")
+ (license license:expat)))