aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-11 10:37:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-11 11:40:46 +0300
commitff19460696ff96ca6f49cd1c74c94ba73599dd2a (patch)
tree4193b51e4c5df94c977fa8e63866e45986e6ac87
parentb73814872e5b753588d8f4a126add403d8b390df (diff)
downloadguix-ff19460696ff96ca6f49cd1c74c94ba73599dd2a.tar
guix-ff19460696ff96ca6f49cd1c74c94ba73599dd2a.tar.gz
gnu: vim: Update to 9.0.0719.
* gnu/packages/vim.scm (vim): Update to 9.0.0719. [arguments]: Adjust custom 'skip-or-fix-failing-tests to skip another test assuming shell path filelength.
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 901527e159..ed24c39be2 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -77,7 +77,7 @@
(define-public vim
(package
(name "vim")
- (version "9.0.0594")
+ (version "9.0.0719")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -86,7 +86,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0rb1385pwz75z342b4915gp8212xipp38z9qlaxdqdy3x5m16lcp"))))
+ "1fmy2yf83w9429dp3hyx2l24mffjqmaxqcabdyyjcvmgx7zp3bii"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -99,6 +99,7 @@
"src/testdir/test_filetype.vim"
"src/testdir/test_normal.vim"
"src/testdir/test_popupwin.vim"
+ "src/testdir/test_prompt_buffer.vim"
"src/testdir/test_shell.vim"
"src/testdir/test_suspend.vim"
"src/testdir/test_terminal.vim"
@@ -125,6 +126,9 @@
;; actions. The path of the bash binary is shown, which results in
;; a difference being detected. Patching the expected result is
;; non-trivial due to the special format used, so skip the test.
+ (substitute* "src/testdir/test_messages.vim"
+ ((".*Test_echo_verbose_system.*" line)
+ (string-append line "return\n")))
(substitute* "src/testdir/test_terminal.vim"
((".*Test_open_term_from_cmd.*" line)
(string-append line "return\n"))