aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorM <matf@disr.it>2022-10-09 13:20:55 +0200
committerChristopher Baines <mail@cbaines.net>2022-10-11 12:03:30 +0100
commitfcbe9cf6f8dc0a1bdc120ffe299b0435743bf632 (patch)
treee02680fcff830f40d0975f05c3c98432ab72a34d
parentf40b7ed3762db72d0d1225935bd7ab8432959c84 (diff)
downloadguix-fcbe9cf6f8dc0a1bdc120ffe299b0435743bf632.tar
guix-fcbe9cf6f8dc0a1bdc120ffe299b0435743bf632.tar.gz
gnu: Add python-cobib.
* gnu/packages/python-xyz.scm (python-cobib): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e76073333f..7c647bd42f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -555,6 +555,37 @@ decorators, including variants of the Python standard library's
@code{lru_cache} function decorator.")
(license license:expat)))
+(define-public python-cobib
+ (package
+ (name "python-cobib")
+ (version "3.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cobib" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16nbrbvascbf6cb7yvn9q793dy8zx703pqrmk3mswib9a19mnx3n"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-beautifulsoup4
+ python-bibtexparser
+ python-pylatexenc
+ python-requests
+ python-requests-oauthlib
+ python-ruamel.yaml))
+ (native-inputs
+ (list python-future
+ python-pyte
+ python-pytest))
+ (home-page "https://gitlab.com/mrossinek/cobib")
+ (synopsis "Terminal-based bibliography management tool")
+ (description
+ "@command{cobib} is a command-line based bibliography management tool.
+It uses a plain-text database, a location-independent library, and features
+git integration, command-line support, and a curses-based TUI.")
+ (license license:expat)))
+
(define-public python-colorful
(package
(name "python-colorful")