aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-04 17:00:47 -0500
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commite827d45db92d6e1f9dc68199cd40cb5d67de9d46 (patch)
tree0ecb63f6160ce0e0268e7b37d174a407bc964b7f
parentbdb13dfd29e7b6028f23ca5faa4983848375e7c5 (diff)
downloadguix-e827d45db92d6e1f9dc68199cd40cb5d67de9d46.tar
guix-e827d45db92d6e1f9dc68199cd40cb5d67de9d46.tar.gz
gnu: Add go-webring.
* gnu/packages/web.scm (go-webring): New variable. Hi paren, Thanks for the review. I changed everything but the blog stuff because go-webring is not necessarily used in the context of a blog. A webring can stand on it's own without being associated with a blog. A webring can associate websites that are not blogs or Guix channels ;() Here's v2 all best, jgart Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3262dbbb10..967d4328b5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 cage <cage-dev@twistfold.it>
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8184,6 +8185,33 @@ provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
;; to account for "vendor names".
(properties '((lint-hidden-cve . ("CVE-2019-15520")))))))
+(define-public go-webring
+ (let ((commit "6786a27b0c57df75323217453369c83a4d9f4dea")
+ (revision "0"))
+ (package
+ (name "go-webring")
+ (version (git-version "20220426" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~amolith/go-webring")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xra0mapdmda8n0z6zsgcqppdzvxc47p0fahsdyig5qmpk89ar8l"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~amolith/go-webring"
+ #:install-source? #f))
+ (inputs (list go-github-com-spf13-pflag))
+ (home-page "https://git.sr.ht/~amolith/go-webring")
+ (synopsis "Simple webring implementation")
+ (description
+"@code{go--webring} provides a simple webring implementation as used by
+the Fediring.")
+ (license (list license:cc0 license:bsd-2)))))
+
(define-public archivebox
(package
(name "archivebox")