aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-07 13:30:55 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-08 22:11:21 +0000
commitf5c6e6966c020722700ef0343ab0a6030e2d61b5 (patch)
treee372c72b42cf9163acfc215f8261acc604b8e9a2
parenta0b24d5f8c5813329986b1bd690ed50b5308cc78 (diff)
downloadguix-f5c6e6966c020722700ef0343ab0a6030e2d61b5.tar
guix-f5c6e6966c020722700ef0343ab0a6030e2d61b5.tar.gz
gnu: rust-1.19: Don't include i686-linux in supported-systems.
Currently rust fails to build for i686-linux, so this will avoid computing lots of derivations that depend on rust, but won't be possible to build. * gnu/packages/rust.scm (rust-1.19)[supported-systems]: Switch hardcoding only supporting x86_64-linux for supporting all supported systems, other than i686-linux.
-rw-r--r--gnu/packages/rust.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 98a6bfffa5..1fc540f0f8 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -453,7 +453,9 @@ test = { path = \"../libtest\" }
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (supported-systems '("x86_64-linux"))
+ (supported-systems
+ (delete "i686-linux" ; fails to build, see #35519
+ %supported-systems))
(synopsis "Compiler for the Rust programming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")