aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-06 22:06:45 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-08 15:11:48 +0100
commita0a2449df350bfff0a8ece713aa91d2faacde257 (patch)
treeffb1c440d2636f679aa5d1072b4375bada16eded
parent1f3b7c0289715dc44c96cf019b492c4a8993a875 (diff)
downloadguix-a0a2449df350bfff0a8ece713aa91d2faacde257.tar
guix-a0a2449df350bfff0a8ece713aa91d2faacde257.tar.gz
gnu: Add cl-debug.
* gnu/packages/lisp-xyz.scm: (sbcl-cl-debug, cl-debug, ecl-cl-debug): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e4f4caf595..d7b694685d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5123,6 +5123,36 @@ macro for Common Lisp.")
(define-public cl-printv
(sbcl-package->cl-source-package sbcl-printv))
+(define-public sbcl-cl-debug
+ (let ((commit "b334280806104ee7f7d3aec666bf7e08d2f89b31")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-debug")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kmx-io/cl-debug")
+ (commit commit)))
+ (file-name (git-file-name "cl-debug" version))
+ (sha256
+ (base32 "0w5vxbjsgr3zfpivdmghmhzxskfdvm1p34c8whwps2xlhypxsa78"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/kmx-io/cl-debug")
+ (synopsis "Common Lisp cross-package debugging facility")
+ (description
+ "CL-DEBUG provides a unified way to enable or disable debug-specific code.
+Debugging code can be enabled or disabled relative to program features denoted
+by either a symbol or a keyword.")
+ (license license:isc))))
+
+(define-public ecl-cl-debug
+ (sbcl-package->ecl-package sbcl-cl-debug))
+
+(define-public cl-debug
+ (sbcl-package->cl-source-package sbcl-cl-debug))
+
(define-public sbcl-verbose
(let ((commit "c5b7ecd465be61b35af17ef57564697b88397174")
(revision "1"))