aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-03-08 16:12:13 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-09 16:16:05 +0100
commit973c6f18eb5ac6ee76f742f06ba1589759f4d4bd (patch)
treed914b25adbb68a1d1398d910e1ba039ba1193f55
parent07f77812c44aa3b7a6b963613b783da56110d2f0 (diff)
downloadguix-973c6f18eb5ac6ee76f742f06ba1589759f4d4bd.tar
guix-973c6f18eb5ac6ee76f742f06ba1589759f4d4bd.tar.gz
gnu: guile-next: Reintroduce as a 3.0.x snapshot.
* gnu/packages/guile.scm (guile-next): Rewrite as a 3.0.x snapshot.
-rw-r--r--gnu/packages/guile.scm44
1 files changed, 40 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6662315e78..650fe1289a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -44,6 +44,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages hurd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libunistring)
@@ -324,9 +325,6 @@ without requiring the source code to be rewritten.")
;; Remove on the next rebuild cycle.
(search-patches "guile-2.2-skip-so-test.patch")))
-(define-public guile-next
- (deprecated-package "guile-next" guile-3.0))
-
(define-public guile-3.0/libgc-7
;; Using libgc-7 avoid crashes that can occur, particularly when loading
;; data in to the Guix Data Service:
@@ -348,6 +346,44 @@ without requiring the source code to be rewritten.")
(max-silent-time . 36000))))) ;10 hours (needed on ARM
; when heavily loaded)
+(define-public guile-next
+ (let ((version "3.0.5")
+ (revision "0")
+ (commit "91547abf54d5e0795afda2781259ab8923eb527b"))
+ (package
+ (inherit guile-3.0)
+ (name "guile-next")
+ (version (git-version version revision commit))
+ (source (origin
+ ;; The main goal here is to allow for '--with-branch'.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/guile.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "09i1c77h2shygylfk0av31jsc1my6zjl230b2cx6vyl58q8c0cqy"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-3.0)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-before 'check 'skip-failing-tests
+ (lambda _
+ (substitute* "test-suite/standalone/test-out-of-memory"
+ (("!#") "!#\n\n(exit 77)\n"))
+ (delete-file "test-suite/tests/version.test")
+ #t))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("flex" ,flex)
+ ("gettext" ,gnu-gettext)
+ ("texinfo" ,texinfo)
+ ("gperf" ,gperf)
+ ,@(package-native-inputs guile-3.0)))
+ (synopsis "Development version of GNU Guile"))))
+
(define* (make-guile-readline guile #:optional (name "guile-readline"))
(package
(name name)