aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRon Nazarov via Guix-patches via <guix-patches@gnu.org>2021-03-07 21:21:25 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-08 19:59:03 +0100
commit80599a739d04fb1830ee0169256021764784e850 (patch)
treed31bcc49e08f04ba8669458419b1d90c31f3d8aa
parent40d77b8fee903d9d67c22ea5169abe3cdeac39c2 (diff)
downloadguix-80599a739d04fb1830ee0169256021764784e850.tar
guix-80599a739d04fb1830ee0169256021764784e850.tar.gz
gnu: Add python-mistletoe.
* gnu/packages/markup.scm (python-mistletoe): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/markup.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 95a3eb269e..695eed67b1 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (guix utils)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
@@ -300,3 +302,25 @@ and smu is that smu doesn't support reference style links.")
SAX-like interface. It is compliant to the CommonMark specification,
with a few extensions.")
(license expat)))
+
+(define-public python-mistletoe
+ (package
+ (name "python-mistletoe")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mistletoe" version))
+ (sha256
+ (base32 "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/miyuchina/mistletoe")
+ (synopsis "Extensible Markdown parser in pure Python")
+ (description
+ "The @code{mistletoe} Markdown parser is a CommonMark-compliant Markdown
+parser that supports definitions of custom tokens.
+
+Parsing Markdown into an abstract syntax tree also allows @code{mistletoe} to
+swap out renderers for different output formats, without touching any of the
+core components.")
+ (license expat)))