aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-06 22:10:29 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-08 15:11:48 +0100
commit622489873bb0d46b2c27c127666f19f39fe4c559 (patch)
treeebb81236ae9db59658b8ea397815627ea00c96a4
parenta0a2449df350bfff0a8ece713aa91d2faacde257 (diff)
downloadguix-622489873bb0d46b2c27c127666f19f39fe4c559.tar
guix-622489873bb0d46b2c27c127666f19f39fe4c559.tar.gz
gnu: Add cl-parse.
* gnu/packages/lisp-xyz.scm: (sbcl-parse, cl-parse, ecl-parse): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d7b694685d..2dcffd4052 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -581,6 +581,34 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public ecl-cl-ppcre
(sbcl-package->ecl-package sbcl-cl-ppcre))
+(define-public sbcl-parse
+ (let ((commit "2351ee78acac065fcf10b8713d3f404e2e910786")
+ (revision "1"))
+ (package
+ (name "sbcl-parse")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/massung/parse")
+ (commit commit)))
+ (file-name (git-file-name "parse" version))
+ (sha256
+ (base32 "0l18yabyh7jizm5lgvra0jxi8s1cfwghidi6ix1pyixjkdbjlmvy"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/massung/parse")
+ (synopsis "Monadic parsing for Common Lisp")
+ (description
+ "PARSE is a simple token parsing library for Common Lisp.")
+ (license license:asl2.0))))
+
+(define-public ecl-parse
+ (sbcl-package->ecl-package sbcl-parse))
+
+(define-public cl-parse
+ (sbcl-package->cl-source-package sbcl-parse))
+
(define-public sbcl-ubiquitous
(let ((commit "35eb7bd9e1b3daee1705f6b41260775180cce8af")
(revision "1"))