aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-06 21:51:32 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-08 15:11:48 +0100
commit3eec0e9b63c96f8839dff38881262865d8a14ec9 (patch)
treeab4e13f446dd469ca65dfce436c4e67da85cf6de
parent4c3a003a5e0b48307630fc101767bc04ee0032a4 (diff)
downloadguix-3eec0e9b63c96f8839dff38881262865d8a14ec9.tar
guix-3eec0e9b63c96f8839dff38881262865d8a14ec9.tar.gz
gnu: Add cl-mount-info.
* gnu/packages/lisp-xyz.scm (sbcl-cl-mount-info, cl-mount-info, ecl-cl-mount-info): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b48af1a880..2563b8f799 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15062,3 +15062,36 @@ Lisp.")
(define-public cl-percent-encoding
(sbcl-package->cl-source-package sbcl-percent-encoding))
+
+(define-public sbcl-cl-mount-info
+ (let ((commit "2024f5037a7f63db3e3587dc9972cd7b9318f06b")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-mount-info")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/cage/cl-mount-info.git")
+ (commit commit)))
+ (file-name (git-file-name "cl-mount-info" version))
+ (sha256
+ (base32 "0vza9gj9q42nzb5v8aj22lmn4aqx9vrddsb5a343nbwfz89hbh9x"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cffi" ,sbcl-cffi)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (home-page "https://notabug.org/cage/cl-mount-info.git")
+ (synopsis "Library to get information about mounted filesystems")
+ (description
+ "CL-MOUNT-INFO is a Common Lisp wrapper around @code{getmntent(3)} and
+related C functions to get information about the mounted file system.")
+ (license license:lgpl3))))
+
+(define-public ecl-cl-mount-info
+ (sbcl-package->ecl-package sbcl-cl-mount-info))
+
+(define-public cl-mount-info
+ (sbcl-package->cl-source-package sbcl-cl-mount-info))