aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-06 22:03:01 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-08 15:11:48 +0100
commit1f3b7c0289715dc44c96cf019b492c4a8993a875 (patch)
tree2615b02089927af5bab9974e9352b664b10f90bd
parentd5a474beaabdb73bc21820e4cc5e3eb36122bc8c (diff)
downloadguix-1f3b7c0289715dc44c96cf019b492c4a8993a875.tar
guix-1f3b7c0289715dc44c96cf019b492c4a8993a875.tar.gz
gnu: Add cl-chronicity.
* gnu/packages/lisp-xyz.scm: (sbcl-chronicity, cl-chronicity, ecl-chronicity): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 35a119a0eb..e4f4caf595 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4811,6 +4811,39 @@ Long Painful History of Time\".")
(define-public ecl-local-time
(sbcl-package->ecl-package sbcl-local-time))
+(define-public sbcl-chronicity
+ (package
+ (name "sbcl-chronicity")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chaitanyagupta/chronicity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "chronicity" version))
+ (sha256
+ (base32 "0rzrl9is2v1aqbm0sym0qx3blnpd0bl13dkkmll6mb3983k2mkax"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("lisp-unit" ,sbcl-lisp-unit)))
+ (inputs
+ `(("cl-interpol" ,sbcl-cl-interpol)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("local-time" ,sbcl-local-time)))
+ (home-page "https://github.com/chaitanyagupta/chronicity")
+ (synopsis "Natural language date and time parser for Common Lisp")
+ (description
+ "CHRONICITY is Common Lisp natural language date and time parser inspired
+by Ruby's @code{Chronic}.")
+ (license license:bsd-3)))
+
+(define-public ecl-chronicity
+ (sbcl-package->ecl-package sbcl-chronicity))
+
+(define-public cl-chronicity
+ (sbcl-package->cl-source-package sbcl-chronicity))
+
(define-public sbcl-trivial-mimes
(let ((commit "a741fc2f567a4f86b853fd4677d75e62c03e51d9")
(revision "2"))