aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-06 22:13:29 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-08 15:11:49 +0100
commit1cf22d4759342ded292c93adf2b0231312622d00 (patch)
tree6512c12571b1a090ebeb8467706c8f91aa0f614a
parent622489873bb0d46b2c27c127666f19f39fe4c559 (diff)
downloadguix-1cf22d4759342ded292c93adf2b0231312622d00.tar
guix-1cf22d4759342ded292c93adf2b0231312622d00.tar.gz
gnu: Add cl-re.
* gnu/package/lisp-xyz.scm: (sbcl-re, cl-re, ecl-re): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2dcffd4052..acef021314 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -609,6 +609,37 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public cl-parse
(sbcl-package->cl-source-package sbcl-parse))
+(define-public sbcl-re
+ (let ((commit "cfbc1f482970221e80d445080a188fd5c755cd2c")
+ (revision "1"))
+ (package
+ (name "sbcl-re")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/massung/re")
+ (commit commit)))
+ (file-name (git-file-name "re" version))
+ (sha256
+ (base32 "1y2gq2sckspnq8118bix55p2j43dk9qn3p8a2rplp1ip2qxqbb1i"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("parse" ,sbcl-parse)))
+ (home-page "https://github.com/massung/re")
+ (synopsis "Lua-style Pattern Matching for Common Lisp")
+ (description
+ "RE is a small, portable, lightweight, and quick, regular
+expression library for Common Lisp. It is a non-recursive, backtracing VM.")
+ (license license:asl2.0))))
+
+(define-public ecl-re
+ (sbcl-package->ecl-package sbcl-re))
+
+(define-public cl-re
+ (sbcl-package->cl-source-package sbcl-re))
+
(define-public sbcl-ubiquitous
(let ((commit "35eb7bd9e1b3daee1705f6b41260775180cce8af")
(revision "1"))