aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2018-05-11 17:16:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-11 18:42:42 +0200
commit4f38754180bc880f6986b333b8e15e63709fb550 (patch)
tree52363ee059a0d91bd149b3d8f987efd3cb83d8c4
parent26b8cadf88aeb1dfbc8625f02bbc20ecc0c718de (diff)
downloadguix-4f38754180bc880f6986b333b8e15e63709fb550.tar
guix-4f38754180bc880f6986b333b8e15e63709fb550.tar.gz
gnu: arpack-ng-openmpi: Fix build.
* gnu/packages/maths.scm (arpack-ng-openmpi)[arguments]: Inherit arguments from ARPACK-NG. Previously the 'configure' phase would fail due to the lack of a 'configure' script.
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index edbbdfffb7..6387f71582 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -479,7 +479,10 @@ large scale eigenvalue problems.")
(inputs
`(("mpi" ,openmpi)
,@(package-inputs arpack-ng)))
- (arguments `(#:configure-flags '("--enable-mpi")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments arpack-ng)
+ ((#:configure-flags _ '())
+ ''("--enable-mpi"))))
(synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
(define-public lapack