aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-13 16:20:24 -0500
committerLeo Famulari <leo@famulari.name>2021-02-13 18:04:56 -0500
commitec34ddfae18625582e0de9adacf45f4757f53164 (patch)
treeb3f6057fba48b0c07daf6ab1d2d8dfd461a1ff7d
parent109425192ed30ce74a7730fc0a887a54bf055c95 (diff)
downloadguix-ec34ddfae18625582e0de9adacf45f4757f53164.tar
guix-ec34ddfae18625582e0de9adacf45f4757f53164.tar.gz
gnu: linux-libre 5.4: Update to 5.4.98.
* gnu/packages/linux.scm (linux-libre-5.4-version): Update to 5.4.98. (linux-libre-5.4-pristine-source): Update hash. (deblob-scripts-5.4): Use version 5.4.97.
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 73517fc200..2bd8ec20ba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -371,15 +371,17 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.4-version "5.4.97")
+(define-public linux-libre-5.4-version "5.4.98")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
- linux-libre-5.4-version
+ ;; XXX While linux-libre.fsfla.org is offline, use the cached deblob
+ ;; scripts for the previous version on ci.guix.gnu.org.
+ "5.4.97"
(base32 "0q3gwf3b404brjld7aj9krzv0wdpzvs8fgy088ag7q106cwgqg8i")
(base32 "1xghbbnaisjd0k1klbyn1p7r6r4x5a1bpmkm56a3gh2zvw4s7mj8")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "0gs856v3q3m0q245mf8b9ivds8dizqrgjw27s9kbq3v31886da3i")))
+ (hash (base32 "1ca6pn7pgb9pnlsc1wb6kny7lxjlnwv6ywwxfqrz3273zgb4i8l3")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))