aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-11 00:30:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:51:01 +0100
commiteab45f7cfcff6be5906a3c78bdb56cbda7dc480f (patch)
treefffd2301793fd450405eebdd40a8f8755273b229
parentbd8e08333c25687caea5678d9f1448d5cefc412f (diff)
downloadguix-eab45f7cfcff6be5906a3c78bdb56cbda7dc480f.tar
guix-eab45f7cfcff6be5906a3c78bdb56cbda7dc480f.tar.gz
gnu: Add rust-nu-cli-0.26.
* gnu/packages/shells.scm (rust-nu-cli-0.26): New variable.
-rw-r--r--gnu/packages/shells.scm115
1 files changed, 115 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 3ccbe8ec1b..bb68c4594b 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -930,6 +930,121 @@ Underpinning these utilities are many Scheme interfaces for manipulating
files and text.")
(license gpl3+)))
+(define-public rust-nu-cli-0.26
+ (package
+ (name "rust-nu-cli")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "nu-cli" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1cm560qksr7j55kwfxldfp9ry25dbwnw6l3lmm3pbc0hfwdp1w0r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-arboard" ,rust-arboard-1)
+ ("rust-async-recursion" ,rust-async-recursion-0.3)
+ ("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-bigdecimal" ,rust-bigdecimal-0.2)
+ ("rust-byte-unit" ,rust-byte-unit-4)
+ ("rust-bytes" ,rust-bytes-0.5)
+ ("rust-calamine" ,rust-calamine-0.16)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.5)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-codespan-reporting" ,rust-codespan-reporting-0.11)
+ ("rust-csv" ,rust-csv-1)
+ ("rust-ctrlc" ,rust-ctrlc-3)
+ ("rust-derive-new" ,rust-derive-new-0.5)
+ ("rust-directories-next" ,rust-directories-next-2)
+ ("rust-dirs-next" ,rust-dirs-next-2)
+ ("rust-dtparse" ,rust-dtparse-1)
+ ("rust-dunce" ,rust-dunce-1)
+ ("rust-eml-parser" ,rust-eml-parser-0.1)
+ ("rust-encoding-rs" ,rust-encoding-rs-0.8)
+ ("rust-filesize" ,rust-filesize-0.2)
+ ("rust-fs-extra" ,rust-fs-extra-1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-futures-codec" ,rust-futures-codec-0.4)
+ ("rust-getset" ,rust-getset-0.1)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-htmlescape" ,rust-htmlescape-0.3)
+ ("rust-ical" ,rust-ical-0.7)
+ ("rust-ichwh" ,rust-ichwh-0.3)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-inflector" ,rust-inflector-0.11)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-meval" ,rust-meval-0.2)
+ ("rust-nu-command" ,rust-nu-command-0.26)
+ ("rust-nu-data" ,rust-nu-data-0.26)
+ ("rust-nu-engine" ,rust-nu-engine-0.26)
+ ("rust-nu-errors" ,rust-nu-errors-0.26)
+ ("rust-nu-json" ,rust-nu-json-0.26)
+ ("rust-nu-parser" ,rust-nu-parser-0.26)
+ ("rust-nu-plugin" ,rust-nu-plugin-0.26)
+ ("rust-nu-protocol" ,rust-nu-protocol-0.26)
+ ("rust-nu-source" ,rust-nu-source-0.26)
+ ("rust-nu-stream" ,rust-nu-stream-0.26)
+ ("rust-nu-table" ,rust-nu-table-0.26)
+ ("rust-nu-test-support" ,rust-nu-test-support-0.26)
+ ("rust-nu-value-ext" ,rust-nu-value-ext-0.26)
+ ("rust-num-bigint" ,rust-num-bigint-0.3)
+ ("rust-num-format" ,rust-num-format-0.4)
+ ("rust-num-traits" ,rust-num-traits-0.2)
+ ("rust-parking-lot" ,rust-parking-lot-0.11)
+ ("rust-pin-utils" ,rust-pin-utils-0.1)
+ ("rust-pretty-hex" ,rust-pretty-hex-0.2)
+ ("rust-ptree" ,rust-ptree-0.3)
+ ("rust-query-interface" ,rust-query-interface-0.3)
+ ("rust-quick-xml" ,rust-quick-xml-0.20)
+ ("rust-quickcheck-macros" ,rust-quickcheck-macros-0.9)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-roxmltree" ,rust-roxmltree-0.14)
+ ("rust-rusqlite" ,rust-rusqlite-0.24)
+ ("rust-rust-embed" ,rust-rust-embed-5)
+ ("rust-rustyline" ,rust-rustyline-6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-bytes" ,rust-serde-bytes-0.11)
+ ("rust-serde-ini" ,rust-serde-ini-0.2)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-serde-urlencoded" ,rust-serde-urlencoded-0.7)
+ ("rust-serde-yaml" ,rust-serde-yaml-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-shadow-rs" ,rust-shadow-rs-0.5)
+ ("rust-shadow-rs" ,rust-shadow-rs-0.5)
+ ("rust-shellexpand" ,rust-shellexpand-2)
+ ("rust-strip-ansi-escapes" ,rust-strip-ansi-escapes-0.1)
+ ("rust-sxd-document" ,rust-sxd-document-0.3)
+ ("rust-sxd-xpath" ,rust-sxd-xpath-0.4)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-term" ,rust-term-0.6)
+ ("rust-term-size" ,rust-term-size-0.3)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-titlecase" ,rust-titlecase-1)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-trash" ,rust-trash-1)
+ ("rust-umask" ,rust-umask-1)
+ ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+ ("rust-url" ,rust-url-2)
+ ("rust-users" ,rust-users-0.10)
+ ("rust-uuid" ,rust-uuid-0.8)
+ ("rust-which" ,rust-which-4)
+ ("rust-zip" ,rust-zip-0.5))))
+ (home-page "https://www.nushell.sh")
+ (synopsis "CLI for nushell")
+ (description "CLI for nushell")
+ (license expat)))
+
(define-public rust-nu-command-0.26
(package
(name "rust-nu-command")