aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-11 00:36:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:51:05 +0100
commitcdb999069bcb30685697e3910f547cfeab4e9af8 (patch)
tree887efc759cb8b7bc80a70591ebb0b3b865ad725e
parent21fec9f8fd98d05c34d293c00b68d66396e8e967 (diff)
downloadguix-cdb999069bcb30685697e3910f547cfeab4e9af8.tar
guix-cdb999069bcb30685697e3910f547cfeab4e9af8.tar.gz
gnu: Add rust-nu-plugin-match-0.26.
* gnu/packages/shells.scm (rust-nu-plugin-match-0.26): New variable.
-rw-r--r--gnu/packages/shells.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index b749c34c27..6d43ebb92e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -1381,6 +1381,32 @@ files and text.")
(description "Nushell Plugin")
(license expat)))
+(define-public rust-nu-plugin-match-0.26
+ (package
+ (name "rust-nu-plugin-match")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "nu_plugin_match" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0iifbi739x077wwvjgdjw2h7cr149sznvjl6c5m06llmvniga4sa"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-nu-errors" ,rust-nu-errors-0.26)
+ ("rust-nu-plugin" ,rust-nu-plugin-0.26)
+ ("rust-nu-protocol" ,rust-nu-protocol-0.26)
+ ("rust-nu-source" ,rust-nu-source-0.26)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://www.nushell.sh")
+ (synopsis "Regex match plugin for Nushell")
+ (description
+ "This package provides a regex match plugin for Nushell.")
+ (license expat)))
+
(define-public rust-nu-plugin-post-0.26
(package
(name "rust-nu-plugin-post")