aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-11 00:37:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:51:06 +0100
commit85e9bd7cd0a9beb666851b0ca6e5f4940c373ed8 (patch)
treedfb9d1ca618de7e4b0a84c665bc599f6a92e9d34
parentd33c999b0b3f61252b64955057365740b72f0e01 (diff)
downloadguix-85e9bd7cd0a9beb666851b0ca6e5f4940c373ed8.tar
guix-85e9bd7cd0a9beb666851b0ca6e5f4940c373ed8.tar.gz
gnu: Add rust-nu-plugin-from-bson-0.26.
* gnu/packages/shells.scm (rust-nu-plugin-from-bson-0.26): New variable.
-rw-r--r--gnu/packages/shells.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 6ac3e77b32..8fc8782652 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -1381,6 +1381,36 @@ files and text.")
(description "Nushell Plugin")
(license expat)))
+(define-public rust-nu-plugin-from-bson-0.26
+ (package
+ (name "rust-nu-plugin-from-bson")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "nu_plugin_from_bson" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ywvxlx1i44yz7md5wbd4sadbh2j6nah6ccfpkrls0gjmagqsbvj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bigdecimal" ,rust-bigdecimal-0.2)
+ ("rust-bson" ,rust-bson-0.14)
+ ("rust-nu-errors" ,rust-nu-errors-0.26)
+ ("rust-nu-plugin" ,rust-nu-plugin-0.26)
+ ("rust-nu-protocol" ,rust-nu-protocol-0.26)
+ ("rust-nu-source" ,rust-nu-source-0.26)
+ ("rust-nu-value-ext" ,rust-nu-value-ext-0.26)
+ ("rust-num-traits" ,rust-num-traits-0.2))))
+ (home-page "https://www.nushell.sh")
+ (synopsis "Converter plugin to the bson format for Nushell")
+ (description
+ "This package provides a converter plugin to the bson format for
+Nushell.")
+ (license expat)))
+
(define-public rust-nu-plugin-from-sqlite-0.26
(package
(name "rust-nu-plugin-from-sqlite")