aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy Tai <atai@atai.org>2021-02-09 23:44:06 -0800
committerJelle Licht <jlicht@fsfe.org>2021-02-13 15:05:23 +0100
commit822cd628e67f29ad1ec51a64a349b41b3a596c99 (patch)
treeb3d847452963a018be0fd62175f24e44b78a6d53
parentc63db588272eb03657486d37942d8362ac491f4d (diff)
downloadguix-822cd628e67f29ad1ec51a64a349b41b3a596c99.tar
guix-822cd628e67f29ad1ec51a64a349b41b3a596c99.tar.gz
gnu: tesseract-ocr: Update to 4.1.1-1.97079fa
* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1-1.97079fa Signed-off-by: Jelle Licht <jlicht@fsfe.org>
-rw-r--r--gnu/packages/ocr.scm98
1 files changed, 74 insertions, 24 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..c4e965941a 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,8 +27,19 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages image))
(define-public ocrad
@@ -52,34 +64,71 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))
(define-public tesseract-ocr
- (package
- (name "tesseract-ocr")
- (version "3.04.01")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
- (build-system gnu-build-system)
- (inputs
- `(("leptonica" ,leptonica)))
- (arguments
- '(#:configure-flags
- (let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
- (home-page "https://github.com/tesseract-ocr/tesseract")
- (synopsis "Optical character recognition engine")
- (description
- "Tesseract is an optical character recognition (OCR) engine with very
+ ;; There are useful commits beyond the last official stable release.
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df")
+ (revision "1"))
+ (package
+ (name "tesseract-ocr")
+ (version (git-version "4.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tesseract-ocr/tesseract")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11137a4aaay7qp64vdjd83hz1l089nzi5a0ql0qgk8gn79pyhi98"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)
+ ("python-wrapper" ,python-wrapper)))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libarchive" ,libarchive)
+ ("libcurl" ,curl)
+ ("libtool" ,libtool)
+ ("libtiff" ,libtiff)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
+ (arguments
+ `(#:configure-flags
+ (let ((leptonica (assoc-ref %build-inputs "leptonica")))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ #:tests? #f ; Tests currently result in a segfault
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Don't attempt to download XSL schema.
+ (substitute* "doc/Makefile.am"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))))
+ (add-after 'install 'build-training
+ (lambda _
+ (invoke "make" "training")))
+ (add-after 'build-training 'install-training
+ (lambda _
+ (invoke "make" "training-install"))))))
+ (home-page "https://github.com/tesseract-ocr/tesseract")
+ (synopsis "Optical character recognition engine")
+ (description
+ "Tesseract is an optical character recognition (OCR) engine with very
high accuracy. It supports many languages, output text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
@@ -151,3 +200,4 @@ that allows us to create any hand-written recognition systems with low-cost.")
#t)))))
(inputs
`(("zinnia" ,zinnia)))))
+