aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-11 00:31:22 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:51:02 +0100
commit54add535a0bdb0079b3b77cabafc39eaf5d07525 (patch)
tree15ed5c2a30480e2aaed53945b852aad27fc1b16c
parentc868e878bb67d5687700ccc3fac22f3eb5a5deb9 (diff)
downloadguix-54add535a0bdb0079b3b77cabafc39eaf5d07525.tar
guix-54add535a0bdb0079b3b77cabafc39eaf5d07525.tar.gz
gnu: Add rust-nu-plugin-tree-0.26.
* gnu/packages/shells.scm (rust-nu-plugin-tree-0.26): New variable.
-rw-r--r--gnu/packages/shells.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 162d9cc6c4..8c5444ea30 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -1380,6 +1380,33 @@ files and text.")
(description "Nushell Plugin")
(license expat)))
+(define-public rust-nu-plugin-tree-0.26
+ (package
+ (name "rust-nu-plugin-tree")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "nu_plugin_tree" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1q80fr430igfw9a4qa5l3ydw6xhppzhqf2i6pvfjmdgf2vhflpdr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-derive-new" ,rust-derive-new-0.5)
+ ("rust-nu-errors" ,rust-nu-errors-0.26)
+ ("rust-nu-plugin" ,rust-nu-plugin-0.26)
+ ("rust-nu-protocol" ,rust-nu-protocol-0.26)
+ ("rust-nu-source" ,rust-nu-source-0.26)
+ ("rust-ptree" ,rust-ptree-0.3))))
+ (home-page "https://www.nushell.sh")
+ (synopsis "Tree viewer plugin for Nushell")
+ (description "This package provides a tree viewer plugin for
+Nushell.")
+ (license expat)))
+
(define-public rust-nu-plugin-xpath-0.26
(package
(name "rust-nu-plugin-xpath")