aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Frederickson <jonathan@terracrypt.net>2019-06-06 23:40:00 -0400
committerLudovic Courtès <ludo@gnu.org>2019-06-07 09:57:18 +0200
commitd92acd8acffc33a9b8bc5e5bbe2edac583916f18 (patch)
tree8d57425b50ce0263ae55bc4c2689ab52ab379ebb
parentbedb3457752212328ee2a0df99280dca36c7f11c (diff)
downloadguix-d92acd8acffc33a9b8bc5e5bbe2edac583916f18.tar
guix-d92acd8acffc33a9b8bc5e5bbe2edac583916f18.tar.gz
gnu: Add emacs-xterm-color
* gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543ac5b2c6..272a061998 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15807,3 +15807,23 @@ verb commands which would are normally destructive (such as deletion) are
provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+
+(define-public emacs-xterm-color
+ (let ((commit "a452ab38a7cfae97078062ff8885b5d74fd1e5a6")
+ (version "1.8")
+ (revision "1"))
+ (package
+ (name "emacs-xterm-color")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomontage/xterm-color.git")
+ (commit commit)))
+ (sha256
+ (base32 "02kpajb993yshhjhsizpfcbrcndyzkf4dqfipifhxxng50dhp95i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/atomontage/xterm-color")
+ (synopsis "ANSI & xterm-256 color text property translator for Emacs")
+ (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator.")
+ (license license:bsd-2))))