aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-11-09 20:42:56 +0000
committerChristopher Baines <mail@cbaines.net>2019-07-05 07:54:04 +0100
commite773be4a03f68d1b99996fd96793635949d8a7a1 (patch)
tree464e6b0d2f50890018801bb8fe3a0e1c7dc29468
parent4add773e8c7ae7e7730a8cdef7d69d441a9888fb (diff)
downloadguix-e773be4a03f68d1b99996fd96793635949d8a7a1.tar
guix-e773be4a03f68d1b99996fd96793635949d8a7a1.tar.gz
Add python-drf-nested-routers
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cbcbe6c867..995e81f9a9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -175,6 +175,34 @@ The package includes a module with full coverage of JSON RPC versions 1.0 and
comes with a SOCKS proxy client.")
(license (list license:expat license:bsd-2))))
+(define-public python-drf-nested-routers
+ (package
+ (name "python-drf-nested-routers")
+ (version "0.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "drf-nested-routers" version))
+ (sha256
+ (base32
+ "0d2hb2jdm8s8pfdmkqr8cay1n4prx0l51mypmypjqy2wq6mw7ra6"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-djangorestframework"
+ ,python-djangorestframework)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-django" ,python-pytest-django)))
+ (home-page
+ "https://github.com/alanjds/drf-nested-routers")
+ (synopsis
+ "Nested resources for the Django Rest Framework")
+ (description
+ "Nested resources for the Django Rest Framework")
+ (license #f)))
+
(define-public python-falcon
(package
(name "python-falcon")