aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-07-04 19:24:55 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-07-04 19:25:59 +0200
commit9b5e5eafc6e7d7766dee56186dd9487bc9825c9e (patch)
tree04571b52f5b2e329bfd307147eb040c67e33d266
parent3706c0a43274cef9170b42f0ac09eff96f1829a5 (diff)
downloadguix-9b5e5eafc6e7d7766dee56186dd9487bc9825c9e.tar
guix-9b5e5eafc6e7d7766dee56186dd9487bc9825c9e.tar.gz
gnu: Add sbcl-trivia.quasiquote.
* gnu/packages/lisp.scm (sbcl-trivia.quasiquote): New variable.
-rw-r--r--gnu/packages/lisp.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index daa96403ba..306602ffe7 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6428,3 +6428,17 @@ with Optima, another pattern matching library for Common Lisp. It is meant to
be faster and more extensible than Optima.
This system contains the PPCRE extention.")))
+
+(define-public sbcl-trivia.quasiquote
+ (package
+ (inherit sbcl-trivia.level0)
+ (name "sbcl-trivia.quasiquote")
+ (inputs
+ `(("trivia.trivial" ,sbcl-trivia.trivial)
+ ("fare-quasiquote" ,sbcl-fare-quasiquote)
+ ("fare-quasiquote-readtable" ,sbcl-fare-quasiquote-readtable)))
+ (description "Trivia is a pattern matching compiler that is compatible
+with Optima, another pattern matching library for Common Lisp. It is meant to
+be faster and more extensible than Optima.
+
+This system contains the fare-quasiquote extension.")))