aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-07-04 19:24:44 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-07-04 19:25:59 +0200
commit3706c0a43274cef9170b42f0ac09eff96f1829a5 (patch)
tree69399abe1b57a69e36ecbc1e4c77cfd5977a05fd
parent9d450c6d422f885cb875fd816820e32069c58d38 (diff)
downloadguix-3706c0a43274cef9170b42f0ac09eff96f1829a5.tar
guix-3706c0a43274cef9170b42f0ac09eff96f1829a5.tar.gz
gnu: Add sbcl-trivia.ppcre.
* gnu/packages/lisp.scm (sbcl-trivia.ppcre): New variable.
-rw-r--r--gnu/packages/lisp.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 28b7ae5e11..daa96403ba 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6415,3 +6415,16 @@ with Optima, another pattern matching library for Common Lisp. It is meant to
be faster and more extensible than Optima.
This system contains the base level system of Trivia with a trivial optimizer.")))
+
+(define-public sbcl-trivia.ppcre
+ (package
+ (inherit sbcl-trivia.level0)
+ (name "sbcl-trivia.ppcre")
+ (inputs
+ `(("trivia.trivial" ,sbcl-trivia.trivial)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (description "Trivia is a pattern matching compiler that is compatible
+with Optima, another pattern matching library for Common Lisp. It is meant to
+be faster and more extensible than Optima.
+
+This system contains the PPCRE extention.")))