aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2019-06-15 22:32:19 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-02 18:33:52 +0200
commit2e03bbeb7be35faa1cb5b41c119d378d221266f3 (patch)
tree82ea4cca2c39e66f1377b7bbeb5c8708892d6947
parentc5ab53204eccf2983bfcdc8e6164d02a81e54d23 (diff)
downloadguix-2e03bbeb7be35faa1cb5b41c119d378d221266f3.tar
guix-2e03bbeb7be35faa1cb5b41c119d378d221266f3.tar.gz
gnu: Add emacs-multi-term
* gnu/packages/emacs-xyz.scm (emacs-multi-term): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a27de2f778..d337700914 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16340,3 +16340,35 @@ themselves live in an Org-mode file. As such, this leverages the power of
Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
acting like notes that are made @emph{in} the document.")
(license license:gpl3+)))
+
+(define-public emacs-multi-term
+ (let ((commit "0804b11e52b960c80f5cd0712ee1e53ae70d83a4"))
+ (package
+ (name "emacs-multi-term")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/manateelazycat/multi-term.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0apvidmvb7rv05qjnjhax42ma8wrimik5vxx620dlbv17svz7iyf"))))
+ (build-system emacs-build-system)
+ (inputs `(("zsh" ,zsh)))
+ (home-page "https://github.com/manateelazycat/multi-term")
+ (synopsis "Manage multiple terminal buffers in Emacs")
+ (description
+ "This package enhances @code{term.el} with the following features:
+
+@enumerate
+@item Functions to switch between multiple terminal buffers
+@item List of keys to be intercepted by @code{emacs-multi-term} instead of by
+the underlying terminal
+@item Kills the unused buffer left after exiting the terminal
+@item Kills the running sub-processes along with the terminal when killing the
+it forcibly
+@item Dedicated window for debugging program.
+@end enumerate")
+ (license license:gpl3+))))