aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-02 23:45:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-02 23:59:41 +0200
commit03b6c474454c1f90466435e872a005e296ddcbd0 (patch)
tree485ab5995ea65c754dc877d1fc02d26d304a1fb7
parent0ca25073194a753ee610276622c7c73a2fd22a36 (diff)
downloadguix-03b6c474454c1f90466435e872a005e296ddcbd0.tar
guix-03b6c474454c1f90466435e872a005e296ddcbd0.tar.gz
gnu: alpine: Build reproducibly.
This follows up commit 54278e225e99707c3bd6f9eb37b8906851251b49. * gnu/packages/mail.scm (arguments): Replace Makefile.in substitution with the new ‘--with-date-stamp’ configure-flag.
-rw-r--r--gnu/packages/mail.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c45324d181..6ab0f9358e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2558,7 +2558,8 @@ operators and scripters.")
"/lib")
(string-append "--with-interactive-spellcheck="
(assoc-ref %build-inputs "aspell")
- "/bin/aspell"))
+ "/bin/aspell")
+ "--with-date-stamp=Thu 1 Jan 01:00:01 CET 1970")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-reproducible
@@ -2566,9 +2567,6 @@ operators and scripters.")
;; This removes time-dependent code to make alpine reproducible.
(substitute* "pico/blddate.c"
(("%02d-%s-%d") "1970-01-01"))
- (substitute* (list "alpine/Makefile.in"
- "web/src/alpined.d/Makefile.in")
- (("`date`") "1970-01-01"))
#t)))))
(inputs
`(("ncurses" ,ncurses)