aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 08:56:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-28 08:56:59 +0200
commitc643b492449d37ed2da18326167558d57391dc31 (patch)
tree283e60ff66833ae4bd663bc5a8bc7a1e62e8e4cd
parenta9dac432d9e2fd42c5670881bcc41029e54fdde7 (diff)
downloadguix-c643b492449d37ed2da18326167558d57391dc31.tar
guix-c643b492449d37ed2da18326167558d57391dc31.tar.gz
gnu: Add toot.
* gnu/packages/mastodon.scm (toot): New variable. * gnu/local.mk (GNU_SYSTSEM_MODULES): Register it.
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/mastodon.scm66
2 files changed, 68 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0ddf12d8bd..cf479dc44a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -296,8 +296,9 @@ GNU_SYSTEM_MODULES = \
%D%/packages/lxqt.scm \
%D%/packages/m4.scm \
%D%/packages/machine-learning.scm \
- %D%/packages/man.scm \
%D%/packages/magic-wormhole.scm \
+ %D%/packages/man.scm \
+ %D%/packages/mastodon.scm \
%D%/packages/mail.scm \
%D%/packages/make-bootstrap.scm \
%D%/packages/markup.scm \
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
new file mode 100644
index 0000000000..028745f681
--- /dev/null
+++ b/gnu/packages/mastodon.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mastodon)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+)
+
+(define-public toot
+ (package
+ (name "toot")
+ (version "0.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toot" version))
+ (sha256
+ (base32
+ "1dqv5jckaw3r7dnfns3iygwbfnf27x513qrw2rryzl5y79xrzs1x"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-requests" ,python-requests)
+ ("python-wcwidth" ,python-wcwidth)))
+ (home-page "https://github.com/ihabunek/toot/")
+ (synopsis "Mastodon CLI client")
+ (description "Interact with Mastodon social network from the command line.
+Features include:
+@itemize
+@item Posting, replying, deleting statuses
+@item Support for media uploads, spoiler text, sensitive content
+@item Search by account or hash tag
+@item Following, muting and blocking accounts
+@item Simple switching between authenticated in Mastodon accounts
+@end itemize")
+ (license license:gpl3)))