aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-25 14:35:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-28 19:08:48 +0100
commitb8098cc6916714bb182a302cd3c9d5041d5ef162 (patch)
treead6bee0a6f94ce29f4803108c10fa1ca507e8a97
parenta4b71b32a7f56148364c7a25a7d58dca6004f46b (diff)
downloadguix-b8098cc6916714bb182a302cd3c9d5041d5ef162.tar
guix-b8098cc6916714bb182a302cd3c9d5041d5ef162.tar.gz
gnu: Move espeak to speech.scm.
* gnu/packages/audio.scm (espeak): Move from here ... * gnu/packages/speech.scm (espeak): ... to here.
-rw-r--r--gnu/packages/audio.scm53
-rw-r--r--gnu/packages/emacs-xyz.scm1
-rw-r--r--gnu/packages/speech.scm56
3 files changed, 57 insertions, 53 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 17feeafff2..8962f0b4b9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -624,59 +624,6 @@ guitar amplification and a small range of classic effects, signal processors and
generators of mostly elementary and occasionally exotic nature.")
(license license:gpl3+)))
-(define-public espeak
- (package
- (name "espeak")
- (version "1.48.04")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/espeak/espeak/"
- "espeak-" (version-major+minor version)
- "/espeak-" version "-source.zip"))
- (sha256
- (base32
- "0n86gwh9pw0jqqpdz7mxggllfr8k0r7pc67ayy7w5z6z79kig6mz"))
- (modules '((guix build utils)))
- (snippet
- ;; remove prebuilt binaries
- '(begin
- (delete-file-recursively "linux_32bit")
- #t))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "DATADIR="
- (assoc-ref %outputs "out")
- "/share/espeak-data")
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out")
- "/lib")
- "AUDIO=pulseaudio")
- #:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (chdir "src")
- ;; We use version 19 of the PortAudio library, so we must copy the
- ;; corresponding file to be sure that espeak compiles correctly.
- (copy-file "portaudio19.h" "portaudio.h")
- (substitute* "Makefile"
- (("/bin/ln") "ln"))
- #t)))))
- (inputs
- `(("portaudio" ,portaudio)
- ("pulseaudio" ,pulseaudio)))
- (native-inputs `(("unzip" ,unzip)))
- (home-page "http://espeak.sourceforge.net/")
- (synopsis "Software speech synthesizer")
- (description "eSpeak is a software speech synthesizer for English and
-other languages. eSpeak uses a \"formant synthesis\" method. This allows many
-languages to be provided in a small size. The speech is clear, and can be used
-at high speeds, but is not as natural or smooth as larger synthesizers which are
-based on human speech recordings.")
- (license license:gpl3+)))
-
(define-public infamous-plugins
(package
(name "infamous-plugins")
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6fc7e29a8d..36cc005549 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -111,6 +111,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pdf)
#:use-module (gnu packages scheme)
+ #:use-module (gnu packages speech)
#:use-module (gnu packages xiph)
#:use-module (gnu packages mp3)
#:use-module (gnu packages gettext)
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 5f937f64f9..83792277b4 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,10 +24,12 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
@@ -34,6 +37,59 @@
#:use-module (gnu packages python)
#:use-module (gnu packages textutils))
+(define-public espeak
+ (package
+ (name "espeak")
+ (version "1.48.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/espeak/espeak/"
+ "espeak-" (version-major+minor version)
+ "/espeak-" version "-source.zip"))
+ (sha256
+ (base32
+ "0n86gwh9pw0jqqpdz7mxggllfr8k0r7pc67ayy7w5z6z79kig6mz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; remove prebuilt binaries
+ '(begin
+ (delete-file-recursively "linux_32bit")
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "DATADIR="
+ (assoc-ref %outputs "out")
+ "/share/espeak-data")
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib")
+ "AUDIO=pulseaudio")
+ #:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (chdir "src")
+ ;; We use version 19 of the PortAudio library, so we must copy the
+ ;; corresponding file to be sure that espeak compiles correctly.
+ (copy-file "portaudio19.h" "portaudio.h")
+ (substitute* "Makefile"
+ (("/bin/ln") "ln"))
+ #t)))))
+ (inputs
+ `(("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://espeak.sourceforge.net/")
+ (synopsis "Software speech synthesizer")
+ (description "eSpeak is a software speech synthesizer for English and
+other languages. eSpeak uses a \"formant synthesis\" method. This allows many
+languages to be provided in a small size. The speech is clear, and can be used
+at high speeds, but is not as natural or smooth as larger synthesizers which are
+based on human speech recordings.")
+ (license license:gpl3+)))
+
(define-public mitlm
(package
(name "mitlm")