aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-27 15:39:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-27 15:40:46 +0100
commit8aa1ca85ac5ab4853076d5dd36eea33e42fede4d (patch)
tree9d390b0eecdbf8129762a39a88b156448f26b76e
parentd97283c3a62b1e8ebdac5544b3fcb5eacc330bcd (diff)
downloadguix-8aa1ca85ac5ab4853076d5dd36eea33e42fede4d.tar
guix-8aa1ca85ac5ab4853076d5dd36eea33e42fede4d.tar.gz
gnu: flexbar: Fix reproducibility bug.
* gnu/packages/bioinformatics.scm (flexbar)[arguments]: Add phase "do-not-tune-to-CPU".
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fa672cb8d1..21ad0ead0a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2715,6 +2715,11 @@ results. The FASTX-Toolkit tools perform some of these preprocessing tasks.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-tune-to-CPU
+ (lambda _
+ (substitute* "src/CMakeLists.txt"
+ ((" -march=native") ""))
+ #t))
(replace 'check
(lambda* (#:key outputs #:allow-other-keys)
(setenv "PATH" (string-append (getcwd) ":" (getenv "PATH")))