aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-25 13:58:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-28 19:08:48 +0100
commit7566afb1d29e62c6875d1393fa9d84d12ce5dd4d (patch)
treee5763794a31323cc4566390585313e81ed671894
parentb8098cc6916714bb182a302cd3c9d5041d5ef162 (diff)
downloadguix-7566afb1d29e62c6875d1393fa9d84d12ce5dd4d.tar
guix-7566afb1d29e62c6875d1393fa9d84d12ce5dd4d.tar.gz
gnu: Add eSpeak NG.
* gnu/packages/speech.scm (espeak-ng): New public variable.
-rw-r--r--gnu/packages/speech.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 83792277b4..6508dec66f 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -32,6 +32,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
@@ -90,6 +91,34 @@ at high speeds, but is not as natural or smooth as larger synthesizers which are
based on human speech recordings.")
(license license:gpl3+)))
+(define-public espeak-ng
+ (package
+ (name "espeak-ng")
+ (version "1.49.2")
+ (home-page "https://github.com/espeak-ng/espeak-ng")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "/releases/download/" version
+ "/espeak-ng-" version ".tar.gz"))
+ (sha256
+ (base32 "1d10x9rbvqi2zwcz65fxh04k0x0scnk7732l37laz6xra1ldhzng"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-static")
+ ;; Building in parallel triggers a race condition in 1.49.2.
+ #:parallel-build? #f
+ ;; XXX: Some tests require an audio device.
+ #:tests? #f))
+ (inputs
+ `(("libcap" ,libcap)
+ ("pcaudiolib" ,pcaudiolib)))
+ (synopsis "Software speech synthesizer")
+ (description
+ "eSpeak NG is a software speech synthesizer for more than 100 languages.
+It is based on the eSpeak engine and supports spectral and Klatt formant
+synthesis, and the ability to use MBROLA voices.")
+ (license license:gpl3+)))
+
(define-public mitlm
(package
(name "mitlm")