aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-25 13:28:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-28 19:08:48 +0100
commit5d04ce48d1bfee33e742f0f33031e5318925a833 (patch)
tree33905a538923e8fa35d4de6b2d359ed1adb690fe
parent2422b1b450645af024466097326b63cd08e85e4e (diff)
downloadguix-5d04ce48d1bfee33e742f0f33031e5318925a833.tar
guix-5d04ce48d1bfee33e742f0f33031e5318925a833.tar.gz
gnu: speech-dispatcher: Update to 0.9.0.
* gnu/packages/speech.scm (speech-dispatcher): Update to 0.9.0. [source](uri): Change to new upstream URI. [arguments]: Add --with-kali and --with-baratinoo to #:configure-flags.
-rw-r--r--gnu/packages/speech.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 66ca20d16a..5f937f64f9 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -60,18 +60,20 @@ efficiency through the use of a compact vector representation of n-grams.")
(define-public speech-dispatcher
(package
(name "speech-dispatcher")
- (version "0.8.5")
+ (version "0.9.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://devel.freebsoft.org/pub/"
- "projects/speechd/speech-dispatcher-"
+ (uri (string-append "https://github.com/brailcom/speechd/releases"
+ "/download/" version "/speech-dispatcher-"
version ".tar.gz"))
(sha256
(base32
- "18jlxnhlahyi6njc6l6576hfvmzivjjgfjyd2n7vvrvx9inphjrb"))))
+ "1yd2rb02565picga4gh2a0bvfxbhdyaj0cv9aaj5a8fc5zs29fbk"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static"
+ ;; Disable support for proprietary TTS engines.
+ "--with-kali=no" "--with-baratinoo=no")))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))