aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-11-09 20:42:56 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-01 07:11:59 +0000
commit3ea976669afb2e93941157db6f209ae3915feee6 (patch)
treee673432655b8f9f42fa92ee543461630369170f7
parent7183a6aa54605b59e100b716426cabedf8e2c806 (diff)
downloadguix-3ea976669afb2e93941157db6f209ae3915feee6.tar
guix-3ea976669afb2e93941157db6f209ae3915feee6.tar.gz
Add python-drf-nested-routers
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 839f48ce4f..7b1255f40d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3029,3 +3029,31 @@ applications using Publish and Subscribe (PubSub) and routed Remote Procedure
Calls (rRPC). It is ideal for distributed, multi-client and server applications
such as IoT applications or multi-user database-driven business applications.")
(license license:expat)))
+
+(define-public python-drf-nested-routers
+ (package
+ (name "python-drf-nested-routers")
+ (version "0.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "drf-nested-routers" version))
+ (sha256
+ (base32
+ "0d2hb2jdm8s8pfdmkqr8cay1n4prx0l51mypmypjqy2wq6mw7ra6"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-djangorestframework"
+ ,python-djangorestframework)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-django" ,python-pytest-django)))
+ (home-page
+ "https://github.com/alanjds/drf-nested-routers")
+ (synopsis
+ "Nested resources for the Django Rest Framework")
+ (description
+ "Nested resources for the Django Rest Framework")
+ (license #f)))