aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-05 18:07:45 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-09 00:20:46 +0100
commitf2a64830842939aa3f101109cd0d5635e45c9359 (patch)
tree97aba3dd6c3575e7453013ed78faaa1ad359af7d
parent830eac9c27a35f09db2e28e32ad2f35040ed11ee (diff)
downloadguix-f2a64830842939aa3f101109cd0d5635e45c9359.tar
guix-f2a64830842939aa3f101109cd0d5635e45c9359.tar.gz
gnu: python-xyz: Add python-distlib.
* gnu/packages/python-xyz.scm (python-distlib): New variable.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd107f9648..b2b8c28785 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4449,6 +4449,40 @@ by pycodestyle.")
(define-public python2-autopep8
(package-with-python2 python-autopep8))
+(define-public python-distlib
+ (package
+ (name "python-distlib")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "distlib" version ".zip"))
+ (sha256
+ (base32
+ "08fyi2r246733vharl2yckw20rilci28r91mzrnnvcr638inw5if"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'no-/bin/sh
+ (lambda _
+ (substitute* '("distlib/scripts.py" "tests/test_scripts.py")
+ (("/bin/sh") (which "sh")))
+ #t))
+ (add-before 'check 'prepare-test-env
+ (lambda _
+ (setenv "HOME" "/tmp")
+ ;; NOTE: Any value works, the variable just has to be present.
+ (setenv "SKIP_ONLINE" "1")
+ #t)))))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "https://bitbucket.org/pypa/distlib")
+ (synopsis "Distribution utilities")
+ (description "Distlib is a library which implements low-level functions that
+relate to packaging and distribution of Python software. It is intended to be
+used as the basis for third-party packaging tools.")
+ (license license:psfl)))
+
(define-public python-distutils-extra
(package
(name "python-distutils-extra")