aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-03-04 14:03:53 +0100
committerRoel Janssen <roel@gnu.org>2020-03-08 21:50:32 +0100
commitd0ca79e53d0cc123ab7d8cef9c6b6d7239256f1a (patch)
treec48ec720748faeddf9e3402f6fb9c0bc7116352c
parent30acf2f9593f1a69d711d195969ac2c89b48b7f0 (diff)
downloadguix-d0ca79e53d0cc123ab7d8cef9c6b6d7239256f1a.tar
guix-d0ca79e53d0cc123ab7d8cef9c6b6d7239256f1a.tar.gz
gnu: Add perl-attribute-util.
* gnu/packages/perl.scm (perl-attribute-util): New variable.
-rw-r--r--gnu/packages/perl.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1797766db5..89ee8bc875 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
-;;; Copyright © 2016, 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2018, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
@@ -334,6 +334,33 @@ signal running perl code from another thread, asynchronously, and
sometimes even without using a single syscall.")
(license (package-license perl))))
+(define-public perl-attribute-util
+ (package
+ (name "perl-attribute-util")
+ (version "1.07")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://cpan.metacpan.org/authors/id/D/DA/DANKOGAI/"
+ "Attribute-Util-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z79d845dy96lg0pxw0kr2za0gniwnpn963r7ccajfpj6k7jfw07"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/pod/Attribute::Util")
+ (synopsis "Assorted general utility attributes")
+ (description "This packages provides various utility functions. When used
+without argument, this module provides four universally accessible attributes
+of general interest as follows:
+@itemize
+@item Abstract
+@item Alias
+@item Memoize
+@item Method
+@item SigHandler
+@end itemize")
+ (license (package-license perl))))
+
(define-public perl-autovivification
(package
(name "perl-autovivification")