aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-04 18:29:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-07 22:30:06 +0100
commit9eb456b8c7ec28e794b8774a68ced32935998e32 (patch)
treeed50c512c9d3b5e60c6af79c7c994716097720fa
parent24a4a635fd76a91463c75cfe615929ec482cc2f6 (diff)
downloadguix-9eb456b8c7ec28e794b8774a68ced32935998e32.tar
guix-9eb456b8c7ec28e794b8774a68ced32935998e32.tar.gz
gnu: ccache: Update to 3.7.7.
gnu/packages/ccache.scm (ccache): Update to 3.7.7, update homepage to ccache.dev, get source code from github, remove fortran 77 from description. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ccache.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index b3f0cbbd95..c0aafad1fd 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -30,14 +30,14 @@
(define-public ccache
(package
(name "ccache")
- (version "3.6")
+ (version "3.7.7")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
- version ".tar.xz"))
+ (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
+ version "/ccache-" version ".tar.xz"))
(sha256
- (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
+ (base32 "1kcqii3hr1008gj6jgfsjibwh2ryhsplc9z99m18xwa2zvbddhdp"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ; for test/run
("which" ,(@ (gnu packages base) which))))
@@ -49,11 +49,10 @@
(substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t)))))
- (home-page "https://ccache.samba.org/")
+ (home-page "https://ccache.dev/")
(synopsis "Compiler cache")
(description
"Ccache is a compiler cache. It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
-again. Supported languages are C, C++, Objective-C, Objective-C++, and
-Fortran 77.")
+again. Supported languages are C, C++, Objective-C and Objective-C++.")
(license gpl3+)))