aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 20:39:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-08 22:42:33 +0200
commit30acf2f9593f1a69d711d195969ac2c89b48b7f0 (patch)
treec0d37e4f164bf04d79a0aaf7aab2bf8f05cb52ea
parente5059c95aa375e5941c6d68dd706d93a90f77168 (diff)
downloadguix-30acf2f9593f1a69d711d195969ac2c89b48b7f0.tar
guix-30acf2f9593f1a69d711d195969ac2c89b48b7f0.tar.gz
gnu: Add font-opendyslexic.
* gnu/packages/fonts.scm (font-opendyslexic): New variable. (font-open-dyslexic): Mark as deprecated package.
-rw-r--r--gnu/packages/fonts.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 186e1eecff..c302196104 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Jookia <166291@gmail.com>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Toni Reina <areina@riseup.net>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -1234,22 +1234,22 @@ have been optimized for beautiful display on all common platforms and display
resolutions.")
(license license:asl2.0)))
-(define-public font-open-dyslexic
+(define-public font-opendyslexic
(package
- (name "font-open-dyslexic")
- (version "20160623")
+ (name "font-opendyslexic")
+ (version "0.91.12")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/antijingoist/open-dyslexic.git")
- (commit (string-append version "-Stable"))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0nr7s92nk1kbr459154idnib977ixc70z6g9mbra3lp73nyrmyvz"))))
+ (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append "https://github.com/antijingoist/opendyslexic/"
+ "releases/download/v" version
+ "/opendyslexic-0.910.12-rc2-2019.10.17.zip"))
+ (sha256
+ (base32
+ "11ml7v4iyf3hr0fbnkwz8afb8vi58wbcfnmn4gyvrwh9jk5pybdr"))))
(build-system font-build-system)
- (home-page "https://opendyslexic.org")
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "https://opendyslexic.org/")
(synopsis "Font for dyslexics and high readability")
(description "OpenDyslexic is a font designed to help readability for some
of the symptoms of dyslexia. Letters have heavy weighted bottoms to provide
@@ -1258,12 +1258,10 @@ similar letters. Consistently weighted bottoms can also help reinforce the
line of text. The unique shapes of each letter can help prevent flipping and
swapping. The italic style for OpenDyslexic has been crafted to be used for
emphasis while still being readable.")
- (license
- (license:fsdg-compatible
- "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
- "The Font Software may be sold as part of a larger software package but
-no copy of one or more of the Font Software typefaces may be sold by
-itself."))))
+ (license license:silofl1.1)))
+
+(define-public font-open-dyslexic
+ (deprecated-package "font-open-dyslexic" font-opendyslexic))
(define-public font-dosis
(package