aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-10-20 17:02:36 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-10-20 17:07:15 +0200
commit996deb819fb2207d4bcf07cafe3087dbbd24a9de (patch)
tree4f6279d308b29efcaad8b2e29d6953b001ae2fe8
parentd53ee6bcd2c28e3414b2dbeffb6e15005d414d7e (diff)
downloadguix-996deb819fb2207d4bcf07cafe3087dbbd24a9de.tar
guix-996deb819fb2207d4bcf07cafe3087dbbd24a9de.tar.gz
gnu: Add emacs-async-await.
* gnu/packages/emacs-xyz.scm (emacs-async-await): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a34a355df7..4b593f6a1d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25080,3 +25080,26 @@ faithfully. See @url{https://github.com/then/promise}.
@item It supports \"rejection-tracking\".
@end itemize\n")
(license license:gpl3+)))
+
+(define-public emacs-async-await
+ (package
+ (name "emacs-async-await")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chuntaro/emacs-async-await")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aav9qdswnw7ynqlzn0sm34as5fj2d85syxgg8zjabzp6646ay29"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("promise" ,emacs-promise)
+ ("iter2" ,emacs-iter2)))
+ (home-page "https://github.com/chuntaro/emacs-async-await")
+ (synopsis "Async/Await for Emacs")
+ (description "This is a simple implementation of Async/Await inspired by
+the TypeScript implementation.")
+ (license license:gpl3+)))