aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-10-22 10:44:11 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-22 17:10:25 +0200
commit830ea72799f988b0fb334f9833f37ef147f7ca2c (patch)
tree4da420d80fcd089738390d8dc9c1e7f69774aac5
parent16155bbeb89e3a9c5c6b75613c1e838aa1f3f59a (diff)
downloadguix-830ea72799f988b0fb334f9833f37ef147f7ca2c.tar
guix-830ea72799f988b0fb334f9833f37ef147f7ca2c.tar.gz
gnu: Add lcov-cobertura.
* gnu/packages/code.scm (lcov-cobertura): New variable.
-rw-r--r--gnu/packages/code.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 6d348308ac..e3e4c6738c 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -39,6 +39,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages autogen)
@@ -518,6 +519,28 @@ textual @command{gcov} output to implement the following enhanced
functionality such as HTML output.")
(license license:gpl2+)))
+(define-public lcov-cobertura
+ (package
+ (name "python-lcov-cobertura")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lcov_cobertura" version))
+ (sha256
+ (base32
+ "02ar6yjazlxq4p64cz9gag08bvakmzjrp147jara9wlnlbc96j8g"))))
+ (build-system python-build-system)
+ (home-page "https://eriwen.github.io/lcov-to-cobertura-xml/")
+ (synopsis "LCOV to Cobertura XML converter")
+ (description
+ "The lcov-to-cobertura Python module converts code coverage report files
+in the lcov format to the XML format of
+@uref{http://cobertura.github.io/cobertura/, Cobertura}, a Java code coverage
+tool. It allows continuous integration servers like Jenkins to aggregate
+results and determine build stability.")
+ (license license:asl2.0)))
+
(define-public kcov
(package
(name "kcov")