aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-10-15 15:53:26 -0400
committerJulien Lepiller <julien@lepiller.eu>2020-10-20 00:22:32 +0200
commit7c2f46044bfa75029d9444aa935042f4396c601d (patch)
tree2a33feaba416c954fd802bbc65c9980dba64fa1b
parent0bb718c1b2c8df29ec85a81f002c54061c05ef65 (diff)
downloadguix-7c2f46044bfa75029d9444aa935042f4396c601d.tar
guix-7c2f46044bfa75029d9444aa935042f4396c601d.tar.gz
gnu: python-nbxmpp: Update to 1.0.2.
* gnu/packages/messaging.scm (python-nbxmpp) [version]: Update to 1.0.2. [arguments]<#:tests?>: Remove argument. [native-inputs]: Add glib:bin. [inputs]: Add glib, glib-networking, libsoup, python-idna, python-precis-i18n and python-pygobject. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/messaging.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8673ef7daa..95232a8f56 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mason Hock <chaosmonk@riseup.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -701,17 +702,24 @@ simultaneously and therefore appear under the same nickname on IRC.")
(define-public python-nbxmpp
(package
(name "python-nbxmpp")
- (version "0.6.10")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
(uri
(pypi-uri "nbxmpp" version))
(sha256
- (base32 "1vq89nhamciblyi5579bppnm4sb0zk5cg5hdipfpz174fxvl2wyd"))))
+ (base32 "0vw5drr077w9ks4crnw6pwa4735ycyjdcm54knc3w4in4x5027wr"))))
(build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("glib:bin" ,glib "bin")))
+ (inputs
+ `(("glib" ,glib)
+ ("glib-networking" ,glib-networking)
+ ("libsoup" ,libsoup)
+ ("python-idna" ,python-idna)
+ ("python-precis-i18n" ,python-precis-i18n)
+ ("python-pygobject" ,python-pygobject)))
(synopsis "Non-blocking Jabber/XMPP module")
(description "The goal of this python library is to provide a way for Python
applications to use Jabber/XMPP networks in a non-blocking way. This library