aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-21 16:38:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-21 16:55:56 +0200
commit576a16995ea26cf9d2c5aebe504c7863d1bc26f2 (patch)
treeb875c5be088ead7b62ef63b18765434436711d6d
parent4733c76c555f2e5a9b2c71d70b5e4ae8b351d3e8 (diff)
downloadguix-576a16995ea26cf9d2c5aebe504c7863d1bc26f2.tar
guix-576a16995ea26cf9d2c5aebe504c7863d1bc26f2.tar.gz
gnu: yadifa: Strip spurious store references.
* gnu/packages/dns.scm (yadifa)[arguments]: Add an ‘omit-spurious-references’ phase.
-rw-r--r--gnu/packages/dns.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index cd809fa9b9..5e85aba5ec 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -782,6 +782,13 @@ served by AS112. Stub and forward zones are supported.")
(lambda _
(substitute* "Makefile.in"
((" (etc|var)") ""))
+ #t))
+ (add-after 'configure 'omit-spurious-references
+ (lambda _
+ ;; The many Makefile.in grep this(!) to #define BUILD_OPTIONS.
+ (substitute* "config.log"
+ (("(=/gnu/store/)[^-]*" _ match)
+ (string-append match "...")))
#t)))
#:configure-flags
(list "--sysconfdir=/etc"