aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-21 10:21:29 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-21 10:24:42 +0300
commit5356cec68b9b7b5478d7df542c6a8fc70226b878 (patch)
tree56c0f957cef0dd3f9bbb81240c6e1bc5a54b46f9
parent1210a885463ffe273de58908dc74a091da6e36ce (diff)
downloadguix-5356cec68b9b7b5478d7df542c6a8fc70226b878.tar
guix-5356cec68b9b7b5478d7df542c6a8fc70226b878.tar.gz
gnu: Add emacs-execline.
* gnu/packages/emacs-xyz.scm (emacs-execline): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06d82434ce..2f5488c137 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24771,6 +24771,45 @@ sources. It features syntax highlighting, autocompletion, preview of buffer
or region and use of locally installed binaries.")
(license license:gpl3+)))
+(define-public emacs-execline
+ (let ((commit "c75dd9b2c54d8e59fc35fd4bd98d8e213948a3f5")
+ (revision "1"))
+ (package
+ (name "emacs-execline")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/KAction/emacs-execline/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02q531c9wvdwflhggflnci4a36h2bb90bq25bbhw6i2lvrd9sk55"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "-Q" "-batch" "-L" "."
+ "-l" "t/indent.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://gitlab.com/KAction/emacs-execline/")
+ (synopsis "Major Emacs mode for editing execline scripts")
+ (description
+ "This package provides a major mode for editing execline scripts.
+
+Features:
+@itemize
+@item Syntax highlighting of commends, builtin commands and variable substitution.
+@item Completion of builtin commands.
+@item Working @code{comment-region} command.
+@item Indentation of blocks.
+@item Automatic enable of mode in @file{*.exec} files.
+@item Automatic enable of mode in files with @code{execlineb} interpreter.
+@end itemize\n")
+ (license license:gpl3+))))
+
(define-public emacs-shell-pop
(let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")
(revision "0"))