aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-20 23:42:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-21 00:20:42 -0400
commit1210a885463ffe273de58908dc74a091da6e36ce (patch)
tree8068e51fbf0d22990f4daffb472014fc4647bf25
parent18a29cb36121f0a435e892169d2927374a8ffd8b (diff)
downloadguix-1210a885463ffe273de58908dc74a091da6e36ce.tar
guix-1210a885463ffe273de58908dc74a091da6e36ce.tar.gz
gnu: czmq: Disable the zarmour self test, which fails.
* gnu/packages/networking.scm (czmq)[phases]{patch-tests}: Disable the zarmour self test. Harmonize comments. Drop the FIXME comment; it is for upstream, not Guix.
-rw-r--r--gnu/packages/networking.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b1e8515fa0..bdf2a2fb05 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -900,10 +900,14 @@ more.")
#:phases (modify-phases %standard-phases
(add-before 'check 'patch-tests
(lambda _
- ;; XXX FIXME: Disable the zproc test, which fails on some
- ;; hardware: <https://github.com/zeromq/czmq/issues/2007>.
(substitute* "src/czmq_selftest.c"
+ ;; Disable the zproc test, which fails on some hardware
+ ;; (see: https://github.com/zeromq/czmq/issues/2007).
(("\\{ \"zproc\", zproc_test.*")
+ "")
+ ;; Also disable the zarmour test, which fails as well
+ ;; (see: https://github.com/zeromq/czmq/issues/2125).
+ (("\\{ \"zarmour\", zarmour_test.*")
""))
#t)))))
(inputs