aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-10-19 04:29:31 +0000
committerLudovic Courtès <ludo@gnu.org>2020-10-21 19:19:34 +0200
commit0e2f871c65a7a923b56f4fb609b66b4d8c767b21 (patch)
tree72a54bc53adf2bc23920203f5d834513d029e0c3
parent720fce6daef2763ded98817a0e31653d22e88e8b (diff)
downloadguix-0e2f871c65a7a923b56f4fb609b66b4d8c767b21.tar
guix-0e2f871c65a7a923b56f4fb609b66b4d8c767b21.tar.gz
gnu: visidata: Update to 2.0.1.
* gnu/packages/visidata.scm (visidata): Update to 2.0.1. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/visidata.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
index 68ea401362..6ba2939b4f 100644
--- a/gnu/packages/visidata.scm
+++ b/gnu/packages/visidata.scm
@@ -17,13 +17,13 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages visidata)
- #:use-module (gnu packages databases)
- #:use-module (gnu packages python-science)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages time)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages time)
#:use-module (gnu packages xml)
#:use-module (guix build-system python)
+ #:use-module (guix build utils)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages))
@@ -31,34 +31,34 @@
(define-public visidata
(package
(name "visidata")
- (version "1.5.2")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "visidata" version))
(sha256
(base32
- "10adfyn4gkisvciqawgh2lakkhhnjjxiyp7mzbgcwkq1b3sigpf1"))))
+ "1p4x9fz59ablyjvp18y50zdsapavhzx7w5hk2v8rsar5ill8947v"))))
(build-system python-build-system)
- ;; Tests disabled because they are not packaged with the source tarball.
- ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
- (arguments '(#:tests? #f))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest"))
+ #t)))))
(inputs
- `(("python-dateutil" ,python-dateutil)
- ("python-fonttools" ,python-fonttools)
- ("python-h5py" ,python-h5py)
- ("python-lxml" ,python-lxml)
- ("python-openpyxl" ,python-openpyxl)
- ("python-pandas" ,python-pandas)
- ("python-psycopg2" ,python-psycopg2)
- ("python-pyyaml" ,python-pyyaml)
- ("python-requests" ,python-requests)
- ("python-xlrd" ,python-xlrd)))
+ `(("dateutil" ,python-dateutil)
+ ("requests" ,python-requests)
+ ("lxml" ,python-lxml)
+ ("openpyxl" ,python-openpyxl)
+ ("xlrd" ,python-xlrd)))
+ (native-inputs
+ `(("pytest" ,python-pytest)))
(synopsis "Terminal spreadsheet multitool for discovering and arranging data")
(description
"VisiData is an interactive multitool for tabular data. It combines the
clarity of a spreadsheet, the efficiency of the terminal, and the power of
Python, into a lightweight utility which can handle millions of rows.")
(home-page "https://www.visidata.org/")
- (license (list license:gpl3
- license:expat)))) ;; visidata/vdtui.py
+ (license license:gpl3)))