aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-10-20 17:02:15 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-10-20 17:02:15 +0200
commit074d033a553d58a75658cc287ca9ea8476050be0 (patch)
tree60e7be08e16d22a97e6d4f0998b85e77052a6be8
parent5f92f51955d758e501d76a271a9fa4aa77ed3c0f (diff)
downloadguix-074d033a553d58a75658cc287ca9ea8476050be0.tar
guix-074d033a553d58a75658cc287ca9ea8476050be0.tar.gz
gnu: Add emacs-iter2.
* gnu/packages/emacs-xyz.scm (emacs-iter2): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 60f5c3569e..1a08da2e4e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25025,3 +25025,27 @@ web development.")
;; file and the header of the main elisp file which indicates
;; that it is licensed under the GPL version 3 or later.
(license (list license:mpl2.0 license:gpl3+)))))
+
+(define-public emacs-iter2
+ (package
+ (name "emacs-iter2")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/doublep/iter2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gaq3z2v1q4r9mkyq71dzmqakhi0p8g7ph4z0n3a11rvyc3z9ykx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/doublep/iter2")
+ (synopsis "Reimplementation of Elisp generators")
+ (description "@code{iter2} is a fully compatible reimplementation of
+built-in generator package. It provides @code{iter2-defun} and
+@code{iter2-lambda} forms that can be used in place of @code{iter-defun} and
+@code{iter-lambda}. All other functions and macros (e.g. @code{iter-yield},
+@code{iter-next}) are intentionally not duplicated: just use the ones from the
+original package.")
+ (license license:gpl3+)))