aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-04 23:53:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-05 13:39:05 +0300
commit9c605ee3be3e92b0e7b2e044e3bdae3dde8a28aa (patch)
tree4f52c5aca0a8d086d73b6e40d898ca4b44d9c112
parent70c2f95f80809460e921307d024850e2258fbcbc (diff)
downloadguix-9c605ee3be3e92b0e7b2e044e3bdae3dde8a28aa.tar
guix-9c605ee3be3e92b0e7b2e044e3bdae3dde8a28aa.tar.gz
gnu: Add rust-cordic-0.1.
* gnu/packages/crates-io.scm (rust-cordic-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index da900024f7..478666f713 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4135,6 +4135,29 @@ It is inspired by the Linux kernel's @code{crypto_memneq}.")
semantics than those provided by @code{as} or @code{From}/@code{Into}.")
(license license:expat)))
+(define-public rust-cordic-0.1
+ (package
+ (name "rust-cordic")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cordic" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13zvqn6c8d8lp18p9ik10q100wfsyv2m2n4fca16laq3yw7r231m"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; rust-fixed fails to build
+ #:cargo-inputs (("rust-fixed" ,rust-fixed-1))))
+ (home-page "https://github.com/sebcrozet/cordic")
+ (synopsis "Special functions for fixed-point numbers using the CORDIC method")
+ (description "This package provides special functions for fixed-point
+numbers using the CORDIC method.")
+ (license license:bsd-3)))
+
(define-public rust-core-arch-0.1
(package
(name "rust-core-arch")