aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-10-05 11:07:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-10-05 11:16:47 +0200
commit599954c1377a4fc8936f7f341a678ecb9579a2c6 (patch)
tree9057a3a8eb7da5603252afa5738d7eb1329e722d
parentb97b423e3f61c80d5877dadc95b3f316cd61788f (diff)
downloadguix-599954c1377a4fc8936f7f341a678ecb9579a2c6.tar
guix-599954c1377a4fc8936f7f341a678ecb9579a2c6.tar.gz
images: Add pine64 support.
* gnu/system/images/pine64.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/system/image.scm (arm64-disk-image, arm64-image-type): New variables.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/system/image.scm19
-rw-r--r--gnu/system/images/pine64.scm59
3 files changed, 79 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 979339e5b8..61413069ee 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -646,6 +646,7 @@ GNU_SYSTEM_MODULES = \
%D%/system/vm.scm \
\
%D%/system/images/hurd.scm \
+ %D%/system/images/pine64.scm \
\
%D%/machine.scm \
\
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 2aa6c2ef13..1b5ceb3553 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -65,12 +65,14 @@
efi-disk-image
iso9660-image
+ arm64-disk-image
image-with-os
raw-image-type
qcow2-image-type
iso-image-type
uncompressed-iso-image-type
+ arm64-image-type
image-with-label
system-image
@@ -123,6 +125,18 @@
(label "GUIX_IMAGE")
(flags '(boot)))))))
+(define arm64-disk-image
+ (image
+ (format 'disk-image)
+ (target "aarch64-linux-gnu")
+ (partitions
+ (list (partition
+ (inherit root-partition)
+ (offset root-offset))))
+ ;; FIXME: Deleting and creating "/var/run" and "/tmp" on the overlayfs
+ ;; fails.
+ (volatile-root? #f)))
+
;;;
;;; Images types.
@@ -164,6 +178,11 @@ set to the given OS."
(compression? #f))
<>))))
+(define arm64-image-type
+ (image-type
+ (name 'arm)
+ (constructor (cut image-with-os arm64-disk-image <>))))
+
;;
;; Helpers.
diff --git a/gnu/system/images/pine64.scm b/gnu/system/images/pine64.scm
new file mode 100644
index 0000000000..c738a77078
--- /dev/null
+++ b/gnu/system/images/pine64.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images pine64)
+ #:use-module (gnu bootloader)
+ #:use-module (gnu bootloader u-boot)
+ #:use-module (gnu image)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu services)
+ #:use-module (gnu services base)
+ #:use-module (gnu system)
+ #:use-module (gnu system file-systems)
+ #:use-module (gnu system image)
+ #:use-module (srfi srfi-26)
+ #:export (pine64-barebones-os
+ pine64-image-type))
+
+(define pine64-barebones-os
+ (operating-system
+ (host-name "vignemale")
+ (timezone "Europe/Paris")
+ (locale "en_US.utf8")
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-pine64-lts-bootloader)
+ (target "/dev/vda")))
+ (initrd-modules '())
+ (kernel linux-libre-arm64-generic)
+ (file-systems (cons (file-system
+ (device (file-system-label "my-root"))
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+ (services (cons (service agetty-service-type
+ (agetty-configuration
+ (extra-options '("-L")) ; no carrier detect
+ (baud-rate "115200")
+ (term "vt100")
+ (tty "ttyS0")))
+ %base-services))))
+
+(define pine64-image-type
+ (image-type
+ (name 'pine64-raw)
+ (constructor (cut image-with-os arm64-disk-image <>))))